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Chapter 1
Introduction

Overview
This chapter contains an overview of the Administrative Workstation 
(AWS), including its functions and directory structure.
This chapter contains the following sections:
• Summary of AWS Functions, page 1-1
• AWS Directory and File Structure, page 1-2

Summary of AWS Functions
The AWS is a personal computer (PC) that runs on the Windows XP 
Professional operating system. Utilities are installed on the AWS that 
provide the capability to perform several management functions. 
Typically, an AWS is located at the Operator Services Center (OSC) 
and the Data Operations Center (DOC).
This guide provides procedures for using the following utilities, which 
can be included on the AWS: 
• Message Maintenance Utility—Used to create the Broadcast 

Message and the Message of the Day. After messages are created, 
they are transferred to the Local Support Server (LSS) and then to 
the operator workstation at operator logon. For procedures, see 
Chapter 2, Using Message Maintenance.
The messages are described as follows:
− Broadcast Message—A message to all operators currently 

logged on.
− Message of the Day—A longer message that appears to 

operators when they log on.
An operator can re-display either message at any time during a 
logon session.
AWS User and Installation Guide 1-1
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Introduction
• Outside View program—Used for Tandem terminal emulation to 
access the Service Control Node (SCN) and the Operations, 
Administration, and Maintenance (OAM) facility. For procedures 
on using Outside View, see Chapter 3, Using Outside View 
Terminal Emulation.

• Voice Record Utility (VRU)—Used to record default operator 
greetings and greetings in an operator’s voice. For procedures, see 
Chapter 4, Using the Voice Record Utility.

• FreedomStation application—Used to perform such tasks as 
verifying the accuracy of listings entered through Online Update 
and testing retrieval strategies. No switch connection is supported 
for the FreedomStation application running on an AWS platform, 
which means that no functionality requiring a switch connection is 
available. For information about using FreedomStation, see the 
FreedomStation User’s Guide. 

Note: VoltDelta recommends that you use the AWS PC to run only the 
utilities listed or other utilities as directed by VoltDelta.

AWS Directory and File Structure 
 The installation procedures for the utilities on the AWS allow you to 
accept the default directory or select a new directory to use as the 
destination for the files. However, in most installations, the default 
directories are used. The directory and file structure described in this 
section is based on a default installation. Your AWS might be different.
The AWS and VRU installation programs create the following 
directory structure within the Program Files folder:
VoltDelta
   AWS
     VRU
         SoundBlaster Driver
          VTAPCI

 Table 1-1 describes the AWS folders. (For FreedomStation and 
OutsideView folders and files, refer to the product’s documentation.)
1-2 AWS User and Installation Guide
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Introduction
Table 1-1. AWS Folders

Folder Name Description

AWS Contains the Message Maintenance application. Also used to store the 
Message of the Day (MSGOFDAY.TXT) and the Broadcast Message  
(BRDCST.TXT) text files.

VRU Contains the Voice Record Utility application.

SoundBlaster Driver Contains the device driver for the SoundBlaster card.

VTAPCI Contains programs to test the VTA/SoundBlaster combination. Used 
only by VoltDelta Customer Support.
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Chapter 2
Using Message Maintenance 

Overview
This chapter provides procedures for using VoltDelta’s Message 
Maintenance Utility on the Administrative Workstation (AWS). 
For procedures for installing the Message Maintenance Utility, see 
Chapter 5, Installing the AWS.
This chapter contains the following sections:
• Basic Concepts, page 2-1
• Using the Message Maintenance Interface, page 2-2
• Creating a Message, page 2-5

Basic Concepts
You use the Message Maintenance Utility to create files for the 
Broadcast Message and the Message of the Day. The utility transfers 
the files to the Local Support Servers (LSSs) configured in the utility. 
Immediately after an operator logs on, both the Message of the Day and 
the Broadcast Message appear on the screen.
Once an operator is logged on, the operator workstation periodically 
checks the LSS for a new Broadcast Message or a Message of the Day 
file. If the operator workstation finds a new message file, the operator 
workstation downloads the file. The corresponding icon, Broadcast 
Message or Message of the Day, on the directory assistance screen is 
enabled. After an operator reads the message, the icon appears dimmed 
until the operator workstation downloads a new message. 
AWS User and Installation Guide 2-1
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Using Message Maintenance
Using the Message Maintenance Interface
To start the Message Maintenance Utility and display the Message 
Maintenance window, double-click the Message Maintenance icon on 
your desktop. Alternatively, you can click the Windows Start menu and 
choose the following:
All Programs > AWS > Message Maintenance 
The Message Maintenance window appears, as shown in Figure 2-1. 

Figure 2-1. Message Maintenance Window

Each message file has a window. The window labeled BRDCST 
enables you to create or edit the Broadcast Message. The window 
labeled MSGOFDAY enables you to create or edit the Message of the 
Day. For each message file, you can open only one window at a time.
In the windows, the utility displays message files from the first 
configured LSS. If the utility cannot copy a message file from the first 
LSS, the utility tries to copy a message file from the next LSS. The 
process continues until the utility either finds message files or checks 
the last configured LSS. The status bar at the bottom displays the LSS 
number where the message originated. 

Broadcast 
Message

Message 
of the Day

Status Bar
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Using Message Maintenance
The Message Maintenance window provides menu options, key 
combinations, and buttons. A menu option that you cannot use appears 
dimmed. The following tables describe the menu options, key 
combinations, and buttons.

Table 2-1. File Menu Options—Message Maintenance Utility 

Option Name Description Keys/Button
Configure LSS Displays the LSS Configuration window, in which you 

can assign an LSS for file download.
CTRL + L

New Broadcast 
Message

Displays a new, blank window for you to enter the 
Broadcast Message.

CTRL + B

New Message of 
the Day

Displays a new, blank window for you to enter the 
Message of the Day. 

CTRL + D

Open Broadcast 
Message

Displays the current Broadcast Message from the LSS. CTRL + O

Open Message 
of the Day

Displays the current Message of the Day from the LSS. CTRL + M

Close Closes the message window currently in focus. This 
option does not save data or download data to the LSS. 
All entered, unsaved data is lost. No change is made to 
the message files on the LSS.

Save Saves the message currently in focus and copies it to all 
configured LSSs. If the window is blank when Save is 
selected, the file on the LSS is deleted. 

CTRL + S

Save All Saves the messages in both the Broadcast Message and 
the Message of the Day windows to all configured LSSs. 
If a window is blank when Save All is selected, the files 
on the LSS are deleted.

Print… Prints the window currently in focus on the configured 
printer.

CTRL + P

Print Setup Displays the standard print setup window.
Exit Exits the Message Maintenance Utility.
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Using Message Maintenance
Table 2-2. Edit Menu Options—Message Maintenance Utility 

Option Name Description Keys/Button
Clear Clears the current contents of the message window. CTRL + A

Undo Reverses the last action performed. CTRL + Z

Cut Moves the selected text to the Clipboard. The text is 
deleted from the current location.

CTRL + X

Copy Copies the selected text to the Clipboard. CTRL + C

Paste Pastes the contents of the Clipboard into the window in 
focus at the current cursor position.

CTRL + V

Table 2-3. View Menu Options—Message Maintenance Utility 

Option Name Description
Toolbar When selected, displays the toolbar with the shortcut icons. When cleared, 

this option hides the toolbar.
Status Bar When selected, displays the status bar with the LSS from which the 

message file was retrieved. When cleared, this option hides the status bar.

Table 2-4. Window Menu Options—Message Maintenance Utility 

Option Name Description
Cascade Stacks the windows on top of one another.

Tile Arranges the windows horizontally.

BRDCST When cselected, places the focus on the Broadcast Message window. When 
cleared, this option removes the focus from the Broadcast Message 
window.

MSGOFDAY When selected, places the focus on the Message of the Day window. When 
cleared, this option removes the focus from the Broadcast Message 
window.
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Using Message Maintenance
Creating a Message
The Message Maintenance menu provides several methods to create a 
Broadcast Message or Message of the Day. The following procedure 
describes one method you can use.
1. Start the Message Maintenance Utility. To do so, double-click the 

Message Maintenance icon on your desktop. 
The window labeled BRDCST enables you to create or edit the 
Broadcast Message. The window labeled MSGOFDAY enables 
you to create or edit the Message of the Day. The windows contain 
the current Broadcast Message and Massage of the Day, if any. By 
default, the top window is in focus.
The window contains the current Broadcast Message and Message 
of the Day, if the messages exist at an LSS.

2. Bring into focus the window with the message you want to create. 
To do so, click in the window.

3. If the window is blank (no message appears), skip to step 4. 
If a message text appears, delete the text. Do one of the following
− Press and hold DELETE.
− Choose Edit > Clear.

− Click .
4. Enter the message text. You can use the editing functions described 

in Table 2-2, page 2-4.
The operator workstation uses a variable-length font (also called 
proportional font) and can display up to 18 lines. To be sure that all 
of your message text appears, VoltDelta recommends the following 
limits on the amount of text you enter:
− Broadcast Message—Up to 78 characters.

Table 2-5. Help Menu Option—Message Maintenance Utility 

Option Name Description Keys/Button
About Displays the Message Maintenance software version.
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Using Message Maintenance
− Message of the Day—Up to 80 characters per line.
5. Save the message text. Do one of the following:

− To save the message text in the current window, do one of the 
following:

Choose File > Save.
Press CTRL+S.
Click .

− To save both created messages, choose File > Save All.
A confirmation window appears. 

6. Check your entry. Do one of the following:
− To make changes to your message, click No.
− To cancel your message without saving, click Cancel.
− To save the message, click Yes.
If you click Yes, the utility saves and copies the new message file(s) 
to all configured LSSs. 
When the process is finished, a status window appears for each 
message you saved, as shown in Figure 2-2. The example window 
shows that the Message of the Day was saved and copied to the 
LSSs.

Figure 2-2. Save Status Window—Message Maintenance Utility

If the status is Failed, the message was not copied to the LSS. A 
Failed status indicates the LSS location is incorrect in the Message 
Maintenance utility, the connection to the LSS is down, or the LSS 
is down. Contact VoltDelta Customer Support for assistance.

Alternatively, to create a new message, you can close the message 
window and use menu options or keyboard shortcuts to open a new 
window, as follows:
1. Close the window. Do one of the following:

− Choose File > Close.
− Click the CLOSE button in the upper, right corner of the window.
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Using Message Maintenance
2. Open a window for a new message. 
For a Broadcast Message, do one of the following:
− Choose File > New Broadcast Message.
− Press CTRL+B.
For a Message of the Day, do one of the following
− Choose File > New Message of the Day.
− Press CTRL+D.

Use the methods described in the previous procedure to enter text and 
to save the messages.
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Chapter 3
Using Outside View Terminal Emulation

Overview
This chapter provides procedures for using the Outside View terminal 
emulation program from the Administrative Workstation (AWS). You 
can use Outside View to access the Operations, Administration, and 
Maintenance (OAM) application on the Tandem Service Control Node 
(SCN). Using OAM, you can perform administrative tasks, such as 
requesting reports and maintaining operator accounts. With Outside 
View, you can open one or multiple SCN sessions. 
This chapter contains the following sections:
• Starting Outside View and Accessing the SCN, page 3-1
• Closing Outside View, page 3-4
• Transferring a File From the SCN, page 3-5
• Capturing an SCN Session, page 3-7
• Printing the Current SCN Window, page 3-8

Starting Outside View and Accessing the SCN
To start Outside View and open a session on the SCN, do the 
following:
1. On your desktop, double-click the Outside View icon. Typically, 

the icon is labeled TANDEM WORKSPACE. 
The Outside View Tandem Workspace window appears, as shown 
in Figure 3-1.
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Using Outside View Terminal Emulation
. 

Figure 3-1. Outside View Tandem Workspace

2. Do one of the following to open a retained SCN session, a 
previously saved SCN session, or a new SCN session:
− To open a retained session—Click the icon in the Sessions 

pane in the Tandem Workspace window. Then click the 
RECONNECT button or choose Sessions > Reconnect.
The SCN logon window appears, as shown in Figure 3-2. 

Figure 3-2. Outside View Tandem Workspace Window
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Using Outside View Terminal Emulation
(If you want to retain a session so the icon appears in the 
Sessions pane immediately when the Tandem Workspace 
window opens, choose Session > Retain Session during an SCN 
session.)

− To open a saved session—Choose File > Open Session.
The Open Session File window appears, as shown in Figure 3-
3. The names of previously saved sessions are listed.

. 

Figure 3-3. Outside View Open Session File

Do both of the following:
Click to select a session name. Click OPEN.
Click the RECONNECT button or choose Sessions > Reconnect.

The SCN logon window appears.
− To open a new session—Choose File > New Session.

The Session tab in the Session Settings window appears, as 
shown in Figure 3-4.

. 

Figure 3-4. Outside View Session Settings—Session Tab
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Using Outside View Terminal Emulation
Ensure that the following fields contain the listed values and 
then click OK:

Emulation field—Tandem
I/O field—TCP/IP
Protocol field—Telnet

The TCP/IP tab in the Session Settings window appears, as 
shown in Figure 3-5.

. 

Figure 3-5. Outside View Session Settings—TCP/IP Tab

In the Host name or IP address and port field, enter the IP 
address and port number of the SCN. Click OK. 
The SCN logon window appears, as shown in Figure 3-2, page 
3-2.

Closing Outside View
After you have performed administrative tasks on the SCN, do the 
following to close your Outside View session:
1. Log off OAM and the SCN.  Use procedures in the Operations, 

Administration, and Maintenance Guide.
2. In the Tandem Workspace window, choose File > Exit Outside View 

32.
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Using Outside View Terminal Emulation
Transferring a File From the SCN
Outside View includes a communication protocol called Information 
Xchange Facility (IXF). The IXF protocol is designed especially for 
transferring files between a PC and the SCN. After a file is received at 
your PC, you can use a text editor, such as Notepad, to display, edit, 
and print the file.
To transfer a file from the SCN to the AWS, do the following:
1. Open Outside View and start an SCN session, as described in 

Starting Outside View and Accessing the SCN, page 3-1.
2. In the Tandem Workspace window, choose the following:

Session > Receive File
The IXF Receive dialog window appears, as shown in Figure 3-6.

Figure 3-6. Outside View Receive File Window

3. In the IXF Receive window, enter the following options in the Host 
area and the Local area:
− Host area—This area contains information about the SCN 

from which you are downloading the file. Fields are as follows:
\Machine.$Volume.Subvolume—The name of the SCN is 
included, along with the volume and subvolume location of 
the file. Verify or enter the correct information.
File—Enter the name of the file you want to receive from 
the SCN. You can use the asterisk (*) and question mark (?) 
wildcards to select a range of files. 
Optionally, you can specify the $volume.subvolume.file 
name in this field.
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Using Outside View Terminal Emulation
− Local area—This area contains information about the AWS to 
which you are downloading the file. Fields are as follows:

File Name—Enter the name you want the file to have at the 
AWS. If you do not specify a name, the file is downloaded 
with same name as on the SCN. Note that when you use a 
wildcard to enter the file name in the Host area, you must 
also enter a wildcard in this field.
Download Path—Choose the path and directory where you 
want the file to be stored on the AWS. The name of the 
current directory is always displayed. You can click the 
BROWSE button to select another path and directory.
Options—Generally, accept most of the default values for 
transferring files from the SCN. However, you can select 
the check box Overwrite existing files if you want to replace 
files on the AWS that have the same name as the files being 
received. If you do not check this option, files with the same 
name are not replaced. Also, you can select the Binary check 
box to receive files in binary format.

4. Click OK to initiate the IXF file transfer and begin receiving the file 
or range of files you specified. 
The IXF Receive status window displays the status of the file 
transfer, as shown in Figure 3-7. At the end of a successful file 
transfer, the Status field displays Transfer Complete.

Figure 3-7. Outside View IXF Receive Status Window

5. Click END TRANSFER to close the IXF Receive status window and 
return to Outside View.
3-6 AWS User and Installation Guide
Copyright Volt Delta Resources, LLC, 2006. All rights reserved. This document is issued under license by and remains the confidential 
and proprietary property of Volt Delta Resources, LLC. Not for disclosure to any third party except by written agreement. 



Using Outside View Terminal Emulation
Capturing an SCN Session
Outside View enables you to capture an SCN session to a file on the 
AWS or to a printer.

Note: The number of printed pages in a captured session is difficult to 
estimate. VoltDelta recommends that you capture a session to a file 
rather than to a printer. After you view the file, you can decide whether 
to print the contents.

After you initiate the capture process, all subsequent commands and 
responses to and from the SCN are stored in an ASCII file on the AWS. 
The process stops when you turn off the capture process. When you are 
finished capturing a session, you can use a text editor, such as Notepad, 
to display, edit, and print the file.
To capture an SCN session, do the following:
1. Open Outside View and start an SCN session.
2. Choose the following:

File > Log Incoming > To File
The option displays a check mark to show that capture is turned on.

Note: If you select To Printer instead of To File, the session is directed to 
the printer configured for the AWS.

The Enter Log File Name window appears, as shown in Figure 3-8.

Figure 3-8. Outside View Enter Log File Name Window
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Using Outside View Terminal Emulation
3. In the Enter Log File Name window, enter the following options: 
− Look in—Choose the directory where the file is to be stored on 

the AWS. The Capture directory appears by default.
− File name—Enter the name of the file to contain the data for 

the captured SCN session.
− Files of type—Keep the default value *.log to create a log file.

4. To start capturing and saving the current SCN session, choose 
OPEN.

5. To stop capturing the SCN session, in the Tandem Workspace 
window, choose the following:
File > Log Incoming >To File
The previously displayed check mark is removed to show that 
capture is turned off.

Printing the Current SCN Window
Outside View enables you to print the contents of the currently 
displayed window from an SCN session on the printer configured for 
the AWS.
To print a window from an SCN session, do the following:
1. Open Outside View and start an SCN session.
2. Choose the following:

File > Print Screen
The current window prints on the configured printer.
3-8 AWS User and Installation Guide
Copyright Volt Delta Resources, LLC, 2006. All rights reserved. This document is issued under license by and remains the confidential 
and proprietary property of Volt Delta Resources, LLC. Not for disclosure to any third party except by written agreement. 



Chapter 4
Using the Voice Record Utility

Overview
This chapter provides procedures for using VoltDelta’s Voice Record 
Utility (VRU) on the Administrative Workstation (AWS). The VRU is 
used to record default male and female greetings, as well as personal 
greetings in an operator’s voice.
For procedures for installing the VRU, see Chapter 5, Installing the 
AWS.
This chapter contains the following sections:
• Basic Concepts, page 4-1
• Recording a Greeting, page 4-2
• Reviewing and Saving a Greeting, page 4-6

Basic Concepts
The VRU enables each operator to record a separate personal greeting 
for new, reconnected, and transferred calls. In addition, default 
greetings of the same types can be recorded in male and female voices.
The operator records each greeting and reviews the recording for 
quality. Then a manager reviews the recording. If the recording is 
acceptable, the file is saved. 
The file name for each voice file is a combination of the following:
• VX for voice recording.
• Greeting type, as follows:

− D—New directory assistance (DA) call.
− R—Reconnect call.
− T—Transfer call.

• Greeting language indicator—For example, English (00) or Spanish 
(01).
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Using the Voice Record Utility
• Call type number—The Operator Greeting Index call treatment, a 
number between 00 and 99.

• Gender indicator—M (for male) or F (for female). The value is 
meaningful for default recordings only.

For example, for a default greeting for a new DA call (VXD), in 
English (00), for call type 01, in a female voice (F), the voice file 
number would be VXD0001F.
The personal or default greetings are identified by the logon name 
entered at the VRU. Before recording a personal greeting, an operator 
logs on to the VRU using the same logon name used to log on to the 
operator workstation. The default greetings are identified by the logon 
names GENERICM (for a male default greeting) and GENERICF (for 
a female default greeting). 
For each logon name, including GENERICM and GENERICF, a 
directory of greeting files is created at the VRU and transferred to the 
Local Support Server (LSS). When an operator logs on to an operator 
workstation, the directory of VRU greeting files that matches the 
operator’s logon name is transferred from the LSS to the operator 
workstation. The appropriate greetings play to callers automatically at 
the operator workstation. If a greeting in the operator’s own voice is not 
available or not configured for a call, the default greeting plays.
The sections that follow contain procedures for operators and managers 
to use when recording and reviewing greetings.

Recording a Greeting
For an operator to record and review a greeting, do the following:
1. Put on the headset and plug the headset into the jack.
2. To start the VRU, double-click the Voice Record Utility icon on the 

desktop. 
Alternatively, you can click the Windows Start menu and choose 
the following:
All Programs > AWS > Voice Record

The initial Voice Record Utility window appears, as shown in 
Figure 4-1.
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Figure 4-1. VRU Initial Window

3. Click LOGIN.
 The Local Login Processing window appears, as shown in Figure 
4-2.

Figure 4-2. VRU Local Login Processing Window

4. In the User ID field, enter one of the following, for a personal 
greeting or for a default greeting:
− For a personal greeting, enter the same user name that you use 

to log on to the operator workstation. Press TAB.
− For a default male or female greeting, enter one of the 

following and then press TAB:
GENERICM—For a male default greeting.
GENERICF—For a female default greeting.
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Using the Voice Record Utility
The cursor moves to the Confirm User ID field.
5. In the Confirm User ID field, enter the same logon name again that 

you entered in the User ID field. The entries in the two fields must 
be identical. Press ENTER.
The Voice Record Utility main window appears, as shown in 
Figure 4-3. Table 4-1 describes the fields in the window.

Note: Entries in the RecordUtility.ini file establish the field values in 
the drop-down selection boxes. Refer to Figure 5-1, page 5-8 for 
information about RecordUtility.ini entries.

Figure 4-3. VRU Main Window

Table 4-1. Record Utility Fields 

Field Function

Mode Do not change the default value, Record. The other Mode value, Play 
Back, is used by a manager to listen to a recording for approval.

Language Click the drop-down list and select a language for the recording. The 
default value is English.

Message Type Click the drop-down list and select the type of call for which the 
recording will play. Values are as follows: 
• New Call—default
• Reconnect
• Transfer
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Using the Voice Record Utility
6. To start the recording, click START.
7. Begin speaking when bars appear in the recording meter. (The 

recording meter is located next to the Mode area.)
8. To stop recording, click STOP. Alternatively, if you wait 15 seconds 

after you stop speaking, the recording stops automatically. 
The recording automatically plays back for operator verification. 
The recording is truncated to exclude silences before and after the 
greeting.

Call Type Click the drop-down list and select the greeting in the voice file. 
The values in the drop-down list must correspond to the Operator 
Greeting Index call treatment values. With the Operator Greeting 
Index call treatment, different callers can hear different greeting 
messages. For example, mobile callers can hear a different greeting 
from other callers.
If your site does not use the Operator Greeting Index call treatment, 
this field contains a single value that cannot be changed.

File
(Display only)

Based on your previous selections, this field displays the file number 
for the current recording.

File Info
(Display only)

This field displays the length of the recording, in hundredths of 
seconds.

Status
(Display only)

This field displays the current status of the Voice Record Utility. 
Values are as follows:
• Idle
• Recording
• Playing
• Processing

Playback Gain slider Move the slider to the right to increase the playback volume of the 
recording.

Sidetone Gain slider Move the slider to the right to increase the volume of the sidetone. 
Sidetone is the volume level of the operator’s own voice transmitted 
back to the headset. 

Table 4-1. Record Utility Fields (continued)

Field Function
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Reviewing and Saving a Greeting
After an operator finishes recording a greeting, the manager reviews 
the recording and saves the recording file for transfer to the LSS.
To review an operator’s greeting, do the following:
1. Unplug the operator’s headset, and plug in the manager’s headset.
2. In the Mode area, select Play Back.
3. To listen to the operator’s greeting, click START. Verify that the 

recording is clear and complete. 
If the recording is unacceptable, the operator can re-record the 
greeting.

4. If the recording is acceptable, click SAVE. 
The files are saved and transferred to the LSS and are available for 
download to the operator workstation at operator logon.
After the recording is saved, the operator can record another 
greeting, such as a greeting for reconnect calls.

5. If the operator has recorded all required greetings, click LOGOUT to 
end the recording session for the current operator. 
The initial Voice Record Utility window appears, as shown in 
Figure 4-1, page 4-3. The utility is ready for the next operator to log 
on and record greetings.

6. If you are finished using the VRU for this session, click the X at the 
far right of the Title bar to exit the utility. 
The VRU closes, and the desktop appears. 
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Chapter 5
Installing the AWS

Overview
This chapter provides information for installing the Administrative 
Workstation (AWS) software and the Voice Record Utility (VRU) 
software on the AWS. The AWS software installs the Message 
Maintenance Utility. 
Since the VRU can be installed on the same personal computer (PC) as 
the AWS, the requirements include hardware elements to support both 
applications. However, some sites install the VRU on a separate PC in 
a quieter location than the AWS. To accommodate a separate PC with 
the VRU, the installation procedure makes note of steps that apply only 
when VRU software is installed.
This chapter includes the following sections:
• Step 1. Verify the Hardware and Software Requirements, page 5-1
• Step 2. Disable the Embedded Sound Card (VRU Only), page 5-3
• Step 3. Install the SoundBlaster Driver (VRU Only), page 5-4
• Step 4. Disable the Spatial Setting (VRU Only), page 5-5
• Step 5. Install FreedomStation (Optional), Disable Sound, page 5-6
• Step 6. Install VRU, page 5-6
• Step 7. Edit the RecordUtility.ini File (VRU Only), page 5-7
• Step 8. Install AWS Software, page 5-10
• Step 9. Configure LSSs for Message Maintenance, page 5-11

Step 1. Verify the Hardware and Software 
Requirements

Before you install application software, make sure the prerequisite 
hardware and software is in place.
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Hardware Requirements
The minimum hardware requirements and recommendations for 
running the AWS on Windows XP Professional are as follows:

Note: The hardware elements must be on the Microsoft Hardware 
Compatibility List (HCL) for Windows XP Professional.

• Pentium III processor of 1 GHz or faster.
• 6-GB hard drive.
• 512 MB RAM.
• Floppy disk drive—Not required but recommended for support and 

administrative convenience. A floppy disk drive, if included, 
should be a 1.44 MB 3.5-inch drive.

• Network Interface card (NIC)—Ethernet 10 MBit/sec or greater. 
• 4 Universal Serial Bus (USB) ports.
• CD-ROM drive.
• Mouse.
• VTA-PCI headset adapter card—Required for VRU. The card’s 

serial interface cable connector must be plugged into COM1. The 
VRU software uses the COM1 port to detect the plugging and 
unplugging of the headset.

• Either of the following sound cards—Required for VRU.
− SoundBlaster SB-16 sound card, model CT4750.
− Hong Kong SoundBlaster Clone.

Note: Before you install the sound card, you must disable the 
embedded sound card on the AWS. For instructructions, refer to the 
following section, Disable the Embedded Sound Card (VRU Only), 
page 5-3. 

• PCI slots for the VTA-PCI card and SoundBlaster card—Required 
for VRU. 

• COM1 port—Required for VRU.
• PS/2 port—Required for connection to a standard 101-keyboard.
• Standard 101-keyboard.
5-2 AWS User and Installation Guide
Copyright Volt Delta Resources, LLC, 2006. All rights reserved. This document is issued under license by and remains the confidential 
and proprietary property of Volt Delta Resources, LLC. Not for disclosure to any third party except by written agreement. 



Installing the AWS
Software Requirements
The minimum software requirements and recommendations for running 
the AWS are as follows:

• Microsoft Windows XP Professional operating system, with 
Service Pack 2 or higher. The operating system is not supplied as an 
AWS software deliverable.

• Selected Windows XP security patches that VoltDelta has tested 
and verified. 
Following are the 11 required, approved security patches:
− KB887742
− KB885894
− KB884020
− KB888113
− KB893086
− KB893066
− KB890923
− KB890859
− KB885835
− KB885250
− KB886185

Step 2. Disable the Embedded Sound Card 
(VRU Only)

Complete this step only if the VRU software will be installed on the 
PC.
The VTA-PCI headset adapter card requires either the SoundBlaster 
SB-16, Model CT4750 sound card or the Hong Kong SoundBlaster 
Clone sound card. Before you install the sound card, you must disable 
the embedded sound card on the AWS.
The procedure for disabling the embedded sound card varies according 
to the workstation manufacturer. Following is a n example procedure 
that disables the embedded sound card on an HP COMPAQ D530S; 
however, the procedure provided by your computer manufacturer 
might be different.

Example Procedure
1. Turn on the target workstation.
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Installing the AWS
2. During the initial boot, press the appropriate keyboard key to access 
the BIOS. For example, on some systems you can access the BIOS 
by pressing F2.

3. Choose the following:
Advanced > Device Options

4. Use the cursor to move down to the Audio section.
5. Right-click and select disable.
6. Accept the new setting.
7. Save your change and exit.
Follow the manufacturer’s instructions to install both the SoundBlaster 
and VTA-PCI cards.

Step 3. Install the SoundBlaster Driver (VRU Only)
Complete this step only if the VRU software will be installed on the 
PC.
The installation procedure for the SoundBlaster driver differs 
depending upon whether you are performing a local or network 
installation of AWS.
Use one of the following procedures, depending upon the type of  
installation.

Local Installation 
For a local installation, the executable you need to install the 
SoundBlaster driver is provided with the VRU software.
To install the driver on a target AWS, do the following:
1. Locate a copy of the following SoundBlaster executable:

SBPCI_WebDrvsV5_12_01.exe.
2. Copy the executable to the target AWS.
3. Double-click the executable to invoke the SoundBlaster driver 

Installation Wizard:
 SBPCI_WebDrvsV5_12_01.exe
The InstallShield Wizard starts.

4. Accept all default values in the InstallShield Wizard.
5. When prompted, restart the AWS.
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Installing the AWS
The correct SoundBlaster driver is installed on the target AWS.

Network Installation
For a network installation, if LibertyStation or FreedomStation was 
installed on the Local Support Server (LSS), the executable you need to 
install the SoundBlaster driver is located on the LSS.
To access the LSS and install the driver on a target workstation, do the 
following:
1. From the target AWS, navigate to the following path on the LSS:

\\LSSnn\Install\drivers\sb162

2. Double-click the following file to invoke the SoundBlaster driver 
Installation Wizard:
SBPCI_WebDrvsV5_12_01.exe

3. Accept all default values in the InstallShield Wizard.
4. When prompted, restart the AWS.

The correct SoundBlaster driver is installed on the target AWS.

Step 4. Disable the Spatial Setting (VRU Only)
Complete this step only if the VRU software will be installed on the 
PC.
The VTA-PCI headset adapter card requires that in Windows XP the 
Sound Card setting for Spatial be disabled. To disable the Spatial 
setting, do the following:
1. Navigate to the Spatial field, as follows:

− Start > Control Panel > Sounds and Audio Devices.

− On the Volume tab, click Advanced.
− In the Playback section of the window, click Advanced.

2. In the Advanced Controls for Playback Control window, clear the 
Spatial check box.

3. Close the Advanced Controls for Playback Control window.
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Step 5. Install FreedomStation (Optional), Disable 
Sound

Typically, the following software components reside on an AWS.
• FreedomStation
• VRU
• AWS Software—Message Maintenance
• Outside View
If you are installing a new AWS, install FreedomStation software first, 
before VRU or AWS. For instructions, refer to the FreedomStation 
Installation and Administration Guide.
After you install FreedomStation, disable the FreedomStation sound 
component. Do the following:
• Create an empty HAC.FIL file. The file size is zero.
• Place the empty HAC.FIL in the c:\ows_win\data directory.

Step 6. Install VRU
To install the VRU software on the AWS, do the following:
1. Insert the VRU CD-ROM into the CD-ROM drive on the AWS.
2. Navigate to the root directory and double-click setup.exe.

The InstallShield Wizard starts. The InstallShield setup type is 
Typical. The setup type cannot be changed.
The Welcome window appears.

3. Click NEXT.
The Customer Information window appears.

4. Enter your User Name and Organization. 
5. In the Install this application for area, in most cases, do not change the 

default selection: Anyone who uses this computer (all users). 
Since VoltDelta recommends that you do not use the AWS PC 
other than for OSC management by means of the utilities described 
in this guide, the AWS can remain available to any user with a 
Windows logon. However, if the AWS PC is used for other 
purposes, you might want to limit AWS access for security reasons 
to the user whose logon is used to install the software. In this case, 
select Only for me (Customer Name).

6. Click NEXT.
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The Destination Folder window appears.
7. Click NEXT to accept the following default destination folder:

C:\Program Files\AWS\VRU\
The Ready to Install the Program window appears.

8. Review the values for the installation. Do one of the following:
− If you need to make changes, click BACK.
− Click INSTALL to accept the values and begin installation of the 

program files. 
The Installing Default window appears. The window displays a 
status bar to show the status of the installation. To stop the 
installation, click CANCEL.
The InstallShield Wizard Completed window appears.

9. Click FINISH to exit.
The installation automatically creates entries in the Start Menu and 
on the Windows desktop.
On the Start Menu, the menu selection is as follows:
All Programs > AWS > Voice Record Utility
On the Windows desktop, an icon labeled Voice Record Utility 
appears.

Step 7. Edit the RecordUtility.ini File (VRU Only)
After installation, edit the RecordUtility.ini file to contain site-specific 
values. Before you start to edit, gather the following information:
• Path to LSS.
• Languages, if the Language call treatment is used.
• Operator Greeting Index numbers, if the Operator Greeting Index 

call treatment is used.
To edit the file, do the following:
1. Remove the Read-only Attribute on the RecordUility.ini file. Do 

the following:
− Start Windows Explorer.
− Right-click the following file:

C:\Program Files\VoltDelta\AWS\VRU\RecordUtility.ini
− Select Properties from the drop-down list.
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− Clear the Read-only check box.
− Click OK.

2. Open the RecordUtility.ini file. To do so, double-click the file.
3. Review the entries in each section. Make site-specific changes. 

Refer to Table 5-1 for a description of file entries.

Table 5-1. RecordUtility.ini File

Section Default Values Section Description

[MODE] 
; 0=WSCP Login Req’d...1=local login, 
ie ID=PW 
StandAlone=1

Reserved for future use. Do not remove or change 
the default values.

[INSTALLATION] 
Site=Record Utility Development @ 
Orange

Identifies location where VRU is installed. For 
reference purposes only.

[LSS] 
MaxLSS=2 
LSS1=\\lss1 
LSS2=\\lss2

Identifies the number of and path to LSSs to which 
the VRU sends the voice files. Enter site-specific 
values. 
The MaxLSS value must be equal to the number of 
LSSn entries.

[MESSAGE TYPE] 
MaxMessage=3 
TYPE0=New Call 
TYPE1=Reconnect 
TYPE2=Transfer 
TYPE3=Phrase

Identifies the type of call for which the voice file 
plays. Do not remove or change the default values.
Values appear in a drop-down menu in the Message 
Type field. The VRU uses the selected value when 
creating a file name for a greeting.

[LANGUAGE] 
MaxLanguage=2 
LANG0=English 
LANG1=Spanish

Identifies the language in which a greeting is 
recorded. Values appear in a drop-down menu in 
the Language field. The VRU uses the selected 
value when creating a file name for a voice file.
The values in this section correspond to values for 
the Language call treatment. Enter site-specific 
values.
If the site does not use the Language call treatment, 
set MaxLanguage=1 and LANG0=Language Used, 
such as English.
The MaxLanguage value must be equal to the 
number of LANGn entries. 
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[GREETING TYPE] 
MaxGreet=2 
GREET0=CustomerOne 
GREET1=CustomerTwo

Identifies the greeting in a voice file. Values appear 
in a drop-down menu in the Call Type field. The 
VRU uses the selected value when creating a file 
name for a voice file.
The values in this section correspond to values for 
the Operator Greeting Index call treatment. Based 
on call treatment values, the system selects the 
operator greeting voice file to play. Different callers 
can hear different greeting messages. For example, 
mobile callers can hear a different greeting from 
other callers. Enter site-specific values.
If the site does not use the Operator Greeting Index 
call treatment, set MaxGreet=1 and 
GREET0=Customer Name.
The MaxGreet value must be equal to the number 
of GREETn entries. 

[PHRASES] 
MaxPhrase=5 
PHRASE0=Speak Louder “Please 
repeat that a little louder 
PHRASE1=Speak Slower”Please repeat 
that a little slower 
PHRASE2=Please Spell That”Could 
you please spell that? 
PHRASE3=Call Back Later”Please call 
back later 
PHRASE4=Don’t Call Back”Please 
don’t call again

Reserved for future use. Do not remove or change 
the default values.

[WSCP] 
;there should be 2, so if you only have 1, 
duplicate it! 
HostName1=89.4.x.xx 
HostPort1=20000 
HostName2=89.4.xx 
HostPort2=20000

Reserved for future use. Do not remove or change 
the default values.

[Sound] 
Soundtype=HKSoundBlasterClonePCI 
DirectXBuffersize=40

Identifies the sound card installed in the 
workstation. Enter site-specific values.

Table 5-1. RecordUtility.ini File

Section Default Values Section Description
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Step 8. Install AWS Software 
To install this AWS software providing the Message Maintenance 
Utility, do the following:
1. Insert the ADMINWORKSTN CD-ROM into the CD-ROM drive 

on the AWS.
2. Navigate to the root directory and double-click setup.exe.

The InstallShield Wizard starts. The InstallShield setup type is 
Typical. The setup type cannot be changed.
The Welcome window appears.

3. Click NEXT.
The Customer Information window appears, as shown in Figure 5-
1.
. 

Figure 5-1. AWS Installation—Customer Information Window

4. Enter your User Name and Organization. 
5. In the Install this application for area, in most cases, do not change the 

default selection: Anyone who uses this computer (all users). 
Since VoltDelta recommends that you do not use the AWS PC 
other than for OSC management by means of the utilities described 
in this guide, the AWS can remain available to any user with a 
Windows logon. However, if the AWS PC is used for other 
purposes, you might want to limit AWS access for security reasons 
to the user whose logon is used to install the software. In this case, 
select Only for me (Customer Name).
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6. Click NEXT.
The Destination Folder window appears.

7. Click NEXT to accept the following default destination folder:
C:\Program Files\VoltDelta\AWS\

The Ready to Install the Program window appears.
8. Review the values for the installation. Do one of the following:

−  If you need to make changes, click BACK.
− To accept the values and begin installation of the program files, 

click INSTALL. 
The Installing Administrative Workstation (AWS) window 
appears. The window displays a status bar to show the status of 
the installation. To stop the installation, click CANCEL.
The InstallShield Wizard Completed window appears.

9. Click FINISH to exit.
The installation automatically creates entries in the Windows Start 
Menu and on the Windows desktop.
On the Start menu, the menu selection is as follows:
All Programs > AWS > Message Maintenance

On the Windows desktop, an icon labeled Message Maintenance 
appears.

Step 9. Configure LSSs for Message Maintenance
The Message Maintenance Utility sends message files to and copies 
message files from the LSSs. In the Message Maintenance Utility, you 
must configure the number and the location of the LSSs. 

Adding an LSS To add an LSS to the configuration, do the following:
1. At startup, if the Message Maintenance Utility does not find an 

LSS, the LSS configuration window appears automatically.
To display the LSS Configuration window, do one of the following 
within the Message Maintenance window:
− Choose File > Configure LSS.
− Press CTRL+L.
− Click .
The LSS Configuration window appears, as shown in Figure 5-2.
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Figure 5-2. LSS Configuration Window—Message Maintenance Utility

In Figure 5-2, the Configured LSSs area displays the names and 
locations of the configured LSSs. The text is display only.

2. Enter data into the fields as follows:
− Number—Enter the consecutive number of this LSS, such as 1.
− Location—Enter the machine name of the LSS and the path on 

the LSS of the location where the files are to be transferred.
3. Click SUBMIT to save your changes.

Note: If you entered a Number but did not enter a Location, the 
utility asks if you want to delete the entered LSS. Click Cancel to 
return to the Location field and enter a value.

4. Click OK to close the LSS Configuration window.

Deleting an LSS To delete an LSS from the configuration, do the following:
1. To display the LSS Configuration window, do one of the following 

within the Message Maintenance window:
− Choose File > Configure LSS.
− Press CTRL+L.
− Click .
The LSS Configuration window appears, as shown in Figure 5-2.

2. Do one of the following:
− In the Configured LSSs window, click to select the line 

containing the LSS to delete.
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− In the Number field, enter the number of the LSS to delete.
3. Click REMOVE.
4. To close the LSS Configuration window, click OK.
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Glossary
AWS Administrative Workstation 
PC that provides access to the Operations, Administration, and 
Maintenance (OAM) subsystem on the Service Control Node (SCN). 
OAM provides administrative functions to supervisors and 
administrators at the Operator Service Center (OSC), database and 
system administration personnel, computer operators, and database edit 
personnel. AWS software installs the Message Maintenance Utility.

application Generally, software that performs a specific set of functions. 
Specifically, software that provides DOSS functionality.

ASCII American Standard Code for Information Interchange  
Encoding method used to convert letters, numbers, punctuation, and 
control codes into digital form.

BLOCK Message in the lower-right corner of the screen on block-mode terminals 
(or PC using a terminal emulator to function as a block-mode terminal) 
meaning that the terminal is ready to accept input. See also CONV.

Broadcast Message Text file created by an Operator Services Center (OSC) manager for 
distribution to operator workstations. The message appears at logon but 
can also be displayed during a logon session, at the operator’s 
convenience. 

call completion (CC) DOSS service that enables both directory assistance (DA) and 
intercepted callers to be connected to the requested number without 
hanging up and re-dialing.

call determinant Attribute of a directory assistance (DA) call, such as the trunk group or 
switch ID, used to categorize the call and determine the treatment it 
receives.

call processing DOSS operations required to receive a call from the switch, select a 
workstation, open voice and data links to the operator workstation, direct 
the call to a workstation, and request voice services from the Voice 
Feature Node (VFN).

call treatment Defines call-handling features, grouping, or parameters that are assigned 
to an incoming call and determines applicable, specific announcement 
the caller is to hear, including a recorded announcement to play from the 
Voice Feature Node (VFN) or operator-read text.

CONV Message in the lower-right corner of the screen on block-mode terminals 
(or PC using a terminal emulator to function as a block-mode terminal) 
meaning that the terminal is ready to accept input. See also BLOCK.
AWS User and Installation Guide Glossary-1

Copyright Volt Delta Resources, LLC, 2006. All rights reserved. This document is issued under license by and remains the confidential 
and proprietary property of Volt Delta Resources, LLC. Not for disclosure to any third party except by written agreement.



Glossary
Customer Name 
and Address

(CNA) Database search in which the search key is a telephone number, 
and the yield of the search is the customer name and address associated 
with that number.

DA directory assistance 
InfoExpress product in which the caller dials a service code (for 
example, 411) and receives a telephone number or other information 
verbally from an operator or by an automated announcement. 

default Value supplied by the system when a user does not specify a required 
value.

device profile Network address, installation information, and maintenance history for 
DOSS hardware devices, such as operator workstations, printers, and 
Voice Feature Nodes (VFNs). Listed in the Device Profile table.

DOC Data Operations Center 
Location where the Service Control Node (SCN) resides.

DOSS Delta Operator Services System 
Integrated information retrieval system that provides directory 
assistance, Intercept, Toll and Assist, and call completion services.

echo Sound of the operator’s own voice amplified back through the headset. 
Controlled through settings in the operator profile.

field Designated space on a screen that is intended for specific data entry.
FreedomStation PC used as a multipurpose workstation for performing all directory 

assistance (DA) and call completion functions, and for interacting with 
the Intercept and Toll and Assist functions whenever necessary.

gain Increase in signaling power that can produce loud or annoying sounds 
through the operator’s headset. Controlled through settings in the 
operator profile.

information 
provider

Business or person who supplies information to the public for money. 
For example, the subscriber to a 900 telephone number who provides 
weather information to callers for a fee above the cost of the telephone 
call.

IP address Internet Protocol address 
Unique network address consisting of four parts in the format n.n.n.n, 
where n is a number between 0 and 255 with no leading 0.

LibertyStation PC used as a multipurpose workstation for performing all directory 
assistance (DA) and call completion functions, and for interacting with 
the Intercept and Toll and Assist functions whenever necessary.

logon account Combination of a name and password that enable a user to access 
specified portions of the Service Control Node (SCN) operating system 
and/or the DOSS application. The name, password, and access privileges 
are listed in the user profile.
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LSDB Listing Services Database 
Relational database containing telephone listings and other listing 
information.

LSS Local Support Server 
PC that provides file transfer and print services between the Service 
Control Node (SCN) and the LibertyStation or FreedomStation.

Message 
Maintenance Utility

Utility installed on the AWS, used to create and upload to the Local 
Support Server (LSS) the Broadcast Message and the Message of the 
Day. 

Message of the Day Text file created by an Operator Services Center (OSC) manager for 
distribution to operator workstations. The message appears at logon but 
can also be displayed at the operator’s convenience. The message can 
include up to 17 lines of text.

OAM Operations, Administration, and Maintenance Subsystem 
Application subsystem that serves as the central point of connection for 
all DOSS subsystems. OAM functions encompass operator services 
management, database administration, and computer system operation 
and management. The OAM interface provides access to the Service 
Control Node (SCN) and applications needed to run DOSS.

Online Update Collection of facilities used to add, delete, or change data manually in 
the database. Facilities include emergency (immediate), non-emergency 
(scheduled batch), and special (dead listing retrieval).
Also, the facility that accepts and processes manual data entries for 
insertion into or deletion from the database through batch processing.

operator Person who supplies information to callers. Also called agent.
operator 
workstation

LibertyStation and FreedomStation.

OSC Operator Services Center 
Location in which operators and Service Assistants work.

Outside View Windows application that provides terminal emulation for Tandem, 
UNIX, and other terminal interfaces.

program Set of high-level computer instructions that accomplish a defined task. 
Often used interchangeably with process.

prompt Query that requires a response. For example, a screen message asking 
the user to make a choice, or an audio announcement asking the caller to 
make a choice.

SCN Service Control Node 
Tandem computer that houses the Annoucement Control Process (ACP). 
The SCN provides various DA services in a Delta Operator Services 
System (DOSS) environment. 
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server For PCs, a computer or device on a network that manages network 
resources. For example, a file server stores files, a print server manages 
one or more printers, a network server manages network traffic, and a 
database server processes database queries. On the Service Control Node 
(SCN), a process provides database and computing services. 

sidetone Sound of the operator’s own voice through the headset. Sidetone is 
controlled through settings in the operator profile.

TCP/IP Transmission Control Protocol/Internet Protocol 
Entire suite of protocols based on the Internet Protocol (IP) datagram 
protocol. This includes TCP for connection-oriented service, UDP for 
connectionless service, FTP for file transfer, and TELNET for remote 
terminal-type communications.  TCP/IP is the primary communication 
service used in DOSS, connecting virtually every hardware component 
of the network, including LibertyStations, Workstation Switch Interfaces 
(WSIs), Voice Feature Nodes (VFNs), Service Control Nodes (SCNs), 
and Administrative Workstations (AWSs).

Telnet Transmission Control Protocol/Internet Protocol (TCP/IP) utility that 
enables a user on one computer to remotely use another computer via 
terminal emulation.

terminal emulator Software that enables a PC to access a multiple-processor computer as a 
terminal user. In DOSS, the software that enables the Administrative 
Workstation (AWS) to connect to the Service Control Node (SCN). See 
also Outside View.

third-party Company other than Volt Delta or the customer that supplies a part of 
the DOSS system (either hardware or software).

trace Utility that writes program or channel messages to a screen or log file for 
problem analysis.

user profile SQL tables maintained through the Operations, Administration, and 
Maintenance (OAM) menu facility that are used to ensure system 
security and establish operator workstation screen format, control 
system access, and route communications.

Viewpoint Service Control Node (SCN) console application that makes available 
the event log file for application alarms and informational messages 
created by the Event Message System (EMS).

Viewsys Software application that provides authorized system users the ability to 
view Service Control Node (SCN) system resource use.

VRU Voice Record Utility 
Utility installed on the AWS, used to record default operator greetings 
and greetings in an operator’s voice.
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